Programadores => General Programadores => Mensaje iniciado por: Daemon en 25 de Julio de 2006, 08:53:23 am

Título: Duda sobre EA
Publicado por: Daemon en 25 de Julio de 2006, 08:53:23 am
Hola, chicos!

Tengo una pequeña duda, a ver si alguno de vosotros se ha enfrentado antes a este problema (y lo ha resuelto, claro, :D).

Estoy intentando conectar el Enterprise Architect 6.1 a Eclipse 3.2 mediante el software MDGlink que ofrece Sparxs, para realización de paso de modelos de clases UML a codigo y viceversa, pero ocurre que siguiendo todos los pasos de instalacion (que por otra parte no son demasiados, basta con poner el plugin .jar del MDGlink en el directorio de plugins de eclipse e instalar el software), al abrir EA y decirle que me conecte un proyecto al actual que se encuentra abierto en eclipse, no consigue hacerlo, unicamente abre otra instancia de eclipse y se queda esperando hasta que sale el mensajito de 'Eclipse is not yet loaded, continue waiting?'
En el foro de Sparks he encontrado gente que dice que lo ha resuelto, o sea que consigue conectarlo, pero no dice como. Me he inscrito en ese foro y he preguntado, pero no me han respondido aun. ¿Alguno de vosotros ha trabajado con EA y Eclipse y le ha ocurrido algo similar?

Un saludo.
Título: Duda sobre EA
Publicado por: Daemon en 02 de Agosto de 2006, 10:33:15 am
Al final lo he conseguido haciendo un par de cosas, aunque no se si ambas son necesarias.

Lo primero que hice, viendo que no habia manera de conectar los proyectos, fue generar el codigo a partir del modelo uml (mediante las opciones que posee para ello EA) en el directorio del proyecto de Eclipse, luego cree una clase mediante un wizard dentro del proyecto de eclipse, y desde EA probe a conectar ambos proyectos (solo por probar, pues ya creia que el .jar para el eclipse tenia algun fallo), curiosamente funciono.

Esta bien, al menos es posible realizar el paso del codigo que escribes en Eclipse al modelo UML del proyecto.

Un saludo.